Dismiss Notice

Welcome Guest,
do you want to get VIP for free? Vote for the MotM and help other people and become elected yourself! MotM Vote
  1. quickwick

    quickwick Member

    Error just started happening after hosting for over a year. I try to delete a channel but everytime I do I get " file input/output error "

    I'm not sure what can be done to fix this issue.

    Running 3.0.13.6 on CentOS if that matters.
     
  2. Ridicc

    Ridicc Moderator

    The solution in this case was the following.
     
  3. quickwick

    quickwick Member

    I ran "locale -a" and "locale" and "export LC_ALL=en_US.utf8" in the terminal console on winscp ----- and then went onto teamspeak and tried deleting a channel with no luck. Then rebooted and tried deleting the channel and still no luck.

    This was under /home/ts3user/teamspeak3-server
     
  4. Ridicc

    Ridicc Moderator

    Could you post your logs please?
     
  5. quickwick

    quickwick Member

    Derp told me it was probably a permission issue and had me run some commands
    chown -R ts3:ts3 /home/ts3user/teamspeak3-server/
    chown -R ts3:ts3 /home/ts3user/teamspeak3-server/sql

    but
    All ts3 channels are in /home/ts3user/teamspeak3-server/files/virtualserver_1

    --

    I then checked the logs to see if I could see anything and it indicated me to the error'd channels

    2016-12-30 23:47:54.658722|ERROR |FileListManager| |error getting filelist(it) for 'files/virtualserver_1/channel_87/': Permission denied
    2016-12-30 23:47:57.369513|ERROR |FileListManager| |error getting filelist(it) for 'files/virtualserver_1/channel_86/': Permission denied

    So I changed the permissions for those 2 folders from root to ts3user and suddenly the error was gone and I was able to delete the channels.

    chown -R ts3:ts3 /home/ts3user/teamspeak3-server/files/virtualserver_1 <<< should work
     
  6. Derp

    Derp WebApp Dev-Team TS3 Dev-Team Contributor

    /Solved
     

Share This Page