Client R4P3 Client Crash/Anti-Crash [3.1 beta]

Discussion in 'Downloads and Information' started by dedmen, Aug 21, 2016.

  1. dedmen

    dedmen TS3 Dev-Team Contributor

    This plugin provides a hotfix addressing a recently discovered vulnerability affecting TeamSpeak3 Client version 3.1 beta
    It also provides a PoC Utility to exploit the vulnerability!


    Only use it on your own Server for test purposes!
    R4P3.NET wont take responsibility for damage caused.

    You need to register to view spoilers!
    You need to register to view spoilers!

    This doesnt prevent crash if the String is still in the Chatlogs!

    .
    -R4P3-DevTeam // Dedmen
     
    Asphyxia likes this.
  2. Asphyxia

    Asphyxia Web Admin Administrator Super Mod

    Here is the video announcing this security issue.
     
  3. Banhammer

    Banhammer New Member

    They fix it even it comes to public officially...
     
  4. quickwick

    quickwick VIP

  5. Stardust342

    Stardust342 New Member

    It's for 3.1 Beta....
     
  6. quickwick

    quickwick VIP

    My bad I figured you could run it with any client but only crash 3.1
     
  7. Anmar

    Anmar New Member

    if i install the plugen i won't get crash right ?
     
  8. dedmen

    dedmen TS3 Dev-Team Contributor

    Correct

    Could have done that :x But... Figured who uses 3.1 anyway.. Dont really think this crasher is that useful but why not release it if we have it anyway
     
    Asphyxia likes this.
  9. jdog31804

    jdog31804 New Member

    how to update to 3.1 ?
     
    Asphyxia likes this.
  10. Asphyxia

    Asphyxia Web Admin Administrator Super Mod

    Settings ---> Options ---> Update Channel: Beta
    Apply
    Restart client, check for update. ;)
     
  11. Krypton

    Krypton New Member

    Does the other have to get 3.1 aswell?
     
  12. Anmar

    Anmar New Member

    :confused: for sure its a 3.1 crasher !
     
  13. lesa

    lesa New Member

    Is this working on 3.0.19.4 version? Thanks in advance.
     
  14. dedmen

    dedmen TS3 Dev-Team Contributor

     
  15. lesa

    lesa New Member

    Is have exploit for version 3.0.19.4? Thanks.
     
  16. dedmen

    dedmen TS3 Dev-Team Contributor

  17. Hashi0

    Hashi0 New Member

    I did it and I did restart ts3 but still Version:3.0.19.4 [Stable] on Windows... help please!
     
  18. NielYmmah

    NielYmmah New Member

    wait so does this crash other clients if you're version 3.1beta or only if they are 3.1beta or also below ?
     
  19. 0x0539

    0x0539 Super Mod

    If they are on 3.1beta, not sure if you also crash yourself if you are also on 3.1beta and send the parameter crash.
     
  20. dedmen

    dedmen TS3 Dev-Team Contributor

    This crasher is outdated now. The bug has been fixed in the latest beta release.
     

Share This Page