Resource R4P3 Client Patch Owida 1.1

this TS³ plugin protects from the client crash "Owida"

  1. Supervisor

    Supervisor Administrator Moderator TS3 Dev-Team

    Supervisor submitted a new resource:

    R4P3 Client Patch Owida - this TS³ plugin protects from the client crash "Owida"

    Read more about this resource...
     
  2. Supervisor

    Supervisor Administrator Moderator TS3 Dev-Team

  3. Kieran

    Kieran Tag me Member of the Month

    Another fix for everyone on your server, disallow guests to send messages.
     
  4. ehthe

    ehthe Contributing Member

    That may not be enough in the future. As soon as there is a server update. Update it :)
     
  5. Kieran

    Kieran Tag me Member of the Month

    Of course it's not a perfect option, but it's a hotfix that works for now
     
  6. skokkk

    skokkk Contributor

    Hey there,
    So a possible patch which either works or won't. It has fixed my server's users from crashing.
    Minimum Windows/Desktop Version: 3.0.19.2 (16-06-22 14:16:25)
    Minimum Android Version: 1407159763
    Minimum iOS Version: 1407159763

    This makes the crash client give an error saying: "Error: client version outdated, please update"
    It does not even join the server :)

    Coincidence? Maybe, if not - simple fix for server owners. Can others confirm please.
     
  7. ehthe

    ehthe Contributing Member

    This is absolutely the wrong way about it. The version that the exploit uses can be changed very easily. Meaning it could use latest version.
    Have a look at : https://r4p3.net/threads/r4p3-server-fix-owida.4964/
    I would say that it is the most appropriate solution until a new server build is released.

    But then again if for some reason you can't add that ban reason but can change minimal client version, well go ahead, that will prevent the current abuse.
     
  8. skokkk

    skokkk Contributor

    Thanks! That makes a bit more sense - It's easy for you to change the version on the crash (which I hope I haven't convinced you to do), but the ban will fix it aswell :)
     
  9. can someone send me the compiled version of the plugin please
     
  10. Supervisor

    Supervisor Administrator Moderator TS3 Dev-Team

    You may want to look int bin wheree the compiled plugin for 32bit and 64bit is located at.
     
  11. ehthe

    ehthe Contributing Member

    src: http://forum.teamspeak.com/threads/131767-Beta-Channel-TeamSpeak-3-Client-3-1-5?p=449014#post449014

    I did not test this beta, but if the dev did their work correctly, by updating you should no longer need the plugin.
    Now they need to patch the server.

    EDIT : They just did. Today is a nice day.
     
    Last edited: Jul 19, 2017 at 3:36 PM

Share This Page