SinusBot 0.9.18 Unlimited instances [Ubuntu]

I recently I installed this script but it doesn't work well. I start the script and when I start he doesn't turn on in web and if I check the logs, they have lot of symbols and they are imperceptible. Can you help me? I will attach the screenshot of my logs.
 

Qraktzyl

Retired Staff
I recently I installed this script but it doesn't work well. I start the script and when I start he doesn't turn on in web and if I check the logs, they have lot of symbols and they are imperceptible. Can you help me? I will attach the screenshot of my logs.
Those symbols are probably due to wrong locale on your server. Which linux distro are you using?
Can you give me the result of running the "locale" command in your terminal?
 
Hi,
I'm usin linux distro:
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty


I run commands to start the bot and view logs at /root
I located docker files into /root/docker
And I have sinusbot files in /opt/ts3soundboard
 
2017/06/11 11:36:30 The parameter ‘-RunningAsRootIsEvilAndIKnowThat’ has been disabled for security reasons.

Please help me get such an error when I run sinusbot
 

Joxiii

Discord hater!
2017/06/11 11:36:30 The parameter ‘-RunningAsRootIsEvilAndIKnowThat’ has been disabled for security reasons.

Please help me get such an error when I run sinusbot
because you run with root user add -RunningAsRootIsEvilAndIKnowThat after the start command. Like this :
Code:
./sinusbot -RunningAsRootIsEvilAndIKnowThat
 
with new version of sinus, we need to add a sinusbot diferent user. im try to do it but i cant, so how we add a user inside docker when we install the script, and how we chamge it to be allowed to run again? if someone can help.
 
dockerfile
Code:
......
EXPOSE 8087
RUN useradd -ms /bin/bash sinusbot
RUN chown -R sinusbot:sinusbot /opt/ts3soundboard
CMD ["/run.sh"]
run.sh
Code:
......
su sinusbot -c "/opt/ts3soundboard/sinusbot"
 
hey guys
i have problem :X
Step 1/8 : FROM debian:jessie
error parsing HTTP 403 response body: invalid character '<' looking for beginning of value: "<html><body><h1>403 Forbidden</h1>\nSince Docker is a US company, we must comply with US export control regulations. In an effort to comply with these, we now block all IP addresses that are located in Cuba, Iran, North Korea, Republic of Crimea, Sudan, and Syria. If you are not in one of these cities, countries, or regions and are blocked, please reach out to
You do not have permission to view link Log in or register now.
</body></html>\n\n"

i need some one to help me for the files , i cant use " docker build -t ts3soundboard098 /home/tsbot/mydockerscript/sinusbot-master/ "
 
hello after every time i try to run the docker , it tells me that in logs:-
This version has expired. Please download a newer version from the official SinusBot website and upgrade.
 

Nicer

Moderator
Developer
Replace
Code:
RUN cd /opt/ts3soundboard/ && wget https://www.sinusbot.com/pre/sinusbot-0.9.18-8499d2c.tar.bz2
with
Code:
 RUN cd /opt/ts3soundboard/ && https://www.sinusbot.com/dl/sinusbot-beta.tar.bz2
and replace
Code:
 RUN cd /opt/ts3soundboard/ && tar -xjvf sinusbot-0.9.18-8499d2c.tar.bz2
with
Code:
RUN cd /opt/ts3soundboard/ && tar -xjvf sinusbot-beta.tar.bz2
It should be the latest download so it should run.
 
Hello,

i got a problem that the Sinusbot is restarting every 4 to 6 Hours. so i have to reinstall every dockers container.
Can i turn off the container restart in dockers?

Best Regards
 
Replace
Code:
RUN cd /opt/ts3soundboard/ && wget https://www.sinusbot.com/pre/sinusbot-0.9.18-8499d2c.tar.bz2
with
Code:
 RUN cd /opt/ts3soundboard/ && https://www.sinusbot.com/dl/sinusbot-beta.tar.bz2
and replace
Code:
 RUN cd /opt/ts3soundboard/ && tar -xjvf sinusbot-0.9.18-8499d2c.tar.bz2
with
Code:
RUN cd /opt/ts3soundboard/ && tar -xjvf sinusbot-beta.tar.bz2
It should be the latest download so it should run.
after i did tht i got another error :-
2017/08/09 21:41:43 The parameter '-RunningAsRootIsEvilAndIKnowThat' has been disabled for security reasons.
they disabled running the bot as root ,so is there a solution for that?
 

Top Bottom